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Delphi 2007 - Poderoso e Simples como o Delphi 7
Tela Principal do Delphi 2007, a primeira impressão

que dá, é a falta de espaços, para trabalhar, principalmente
em formulários, na verdade esse é o layout de trablho
padrão que o Delphi traz, mas isso é completamente confi-
gurável.

Na Fig. 1, observamos uma janela dividida
em 3 colunas, a primeira da esquerda é composta
de duas janelas pequenas Structure e Object Ins-

pector, no centro temos a área de trabalho é ai que
montamos os formulários, telas, códigos, etc., na di-
reita temos o Project Mananger, e abaixo o Tool

Palette.

Na parte superior temos o menu principal,
com um item especial, Gerenciador de

Desktop, este item é responsável pelos
diversos layouts que você pode ter, faci-
litando muito o trabalho do desenvolve-
dor, veja a Fig. 2.

Logo abaixo do menu Principal,
nós temos as diversas barra de ferra-
mentas, que normalmente é comum
para os software do Windows, algumas são especí-
ficas do delphi, como: Run (F9), Pause, Reset Pro-

gram (Ctrl + F2), etc.

A partir de agora, vamos configurar o desktop
da melhor maneira possivel.

A primeira ciasa a fazer é aumentar à área de
trabalho, aquela onde será confeccionado os for-
mulários que farão parte do projeto em desenvolvi-
mento, isso é muito simples, primeiro vamos esconder
as janelas da esquerda e da direita, da seguinte
maneira:

No caption das janelas, por exemplo: Structure

tem um desenho parecido com o que está circulado
na Fig. 3, a função deste  ícone é es-
conder a janela na lateral onde ela se
encontra, abrindo assim a área de de-
senvolvimento, esta janela será reexi-
bida quando o mouse se aproximar da
região onde ela está escondida, funcio-
nando mais ou menos como o processo
do menu Iniciar do Windows, quando

está no modo de
Auto-Ocultar ,
isso facilita muito
o trabalho principalmente no desenvolvimento de re-
latórios, cujo layout muitas vezes é extenso e largo. 

Fig. 1

Fig. 2

Fig. 3
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Outras Configurações importantes

Bem, feito a configuração do Desktop, ire-

mos agora fazer pequenas configurações iguais as
feitas no Delphi 7, porém em locais diferentes.

Vejamos o menu File->New, mudanças radi-
cais em relação ao Delphi 7, na Fig. 6,
estaremos mostrando as novas opções,
porém o resultado é praticamente iguais,
só que de uma forma bem mais organi-

zada.

Clique em todos os ícones e veja o resultado, deve ficar exatamente como a Fig. 4

Fig. 4

Veja a direita, na parte superior, as janelas Pro-

ject Mananger e Tool Palette, estão escondi-
das, aumentando assim a área de trabalho. No
lado esquerdo superior, também temos a
mesma situação para as janelas Structure e

Object Inspector.

No próximo passo, vamos dá um nome a
esse Desktop, para isso clique na caixa de texto do
gerenciador de Desktop, digite um nome, no meu
caso digitei Newton, coloque o nome que achar
mais conveniente a você, veja como ficou na Fig. 5.
Bem depois disso não se esqueça de clicar no botão
save currente Desktop.

Pronto o seu layout
está gravado, agora vamos
criar um projeto para ver al-
guns detalhes que foram modificados para melhor,
em relação ao Delphi 7.

Fig. 5

A inovação ganhando

fronteiras

Fone: 11 4718- 3527
Fig. 6
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Configurações gerais do Projeto

Antes de começarmos um projeto, é muito in-
teresante fazer-
mos a
con f igu ração
geral e básica,
para facilitar os
trabalhos de-
senvolvidos nos
projetos, essas
configurações
são válidas para
todos os proje-
tos que se
s e g u i r e m ,
porém é sábio
analisar todas
as opções, para
que a veloci-
dade e a facili-
dade de
administração
seja viável.

Para fazer as alterações das cofigurações
gerais e básicas, crie uma nova aplicação clicando
em File->New, VCL Forms Application - Delphi for

Win32, depois disso clique em Project ->Options...

Na janela
que aparecer,
nós iremos ana-
lisar e configurar
os principais
itens que certa-
mente terá um
efeito muito bom
nos resultados,
veja a janela de
configuração na
Fig. 10.

Veja que já não temos mais a opção Data

Module, que existia no Delphi 7, Calma, não sumi-
ram, nessas opções estão definidas somente as
opções de aplicação 32 bits, formulários, pacotes,
etc.. Bem se
você me per-
guntar, e as ou-
tras, eu te
respondo, está
exatamente ai,
no menu
Other... (ou seja
Outros), veja na
Fig. 7.

Olhe que
nessa janela
está os outros
templates, como
o Data Module,
C o m p o n e n t ,

etc.. Nessa
janela temos
tambem uma in-
finidades de ou-
tros templates,
como .objetos
para Internet,

Web Broker, Web Snap, Web documents, etc., A
grande vantagem que nós temos, eu, particulamente
acho, é à adição da janela Customize, fantástica
voce pode fazer seu menu File->New, da maneira
que voce desejar, veja a Fig. 8.

Nesta tela
você faz o seu
menu File->New,
veja, encontrei o
Data Module, ar-
rastei e soltei
dentro do Delphi
Files, veja agora
como ficou a
janela Menu

Items a direita,
dessa forma
você vai ter
acesso mais
rápido as opções
que normalmente
irá usar nos seus
projetos durante
o dia-a-dia de tra-
balho.

D e p o i s
dessas alterações, clique OK, e verifique como ficou
seu menu File->New. Veja a Fig. 9

Fig. 7

Fig. 8

Fig. 9
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Janela Opções de Projetos

Essa janela é especial,
nela você define um monte de
configuração, que certamente irá
te ajudar no futuro, porém vale
muito prestar atenção, guarde na
mente o máximo de informações
que voce puder.

Na coluna esquerda tem
as configurações que voce irá
modificar, na direita nós temos os
subitens dessas configurações,
por exemplo:

Forms:

-
Na direita voce escolher o

formulário principal (Main Form),
esse form, é a abertura do pro-
grama, Auto-create Forms, são
os formulários que serão criados automaticamente
quando o programa for executado, a desvantagem
desse método, é o consumo de memória, pelo fato
dos fomulários dessa janela serem criados tudo em
memória. Available Forms, esses formulários
devem ser criados e apagados manualmente da
memória, deixando-a livre, isso é muito bom, o pro-
grama vai ser sempre veloz.

Application:

Nesta configuração, voce define o ícone da
aplicação, aquele que aparece quando voce cria um
atalho no Desktop, e aqui voce também define o tí-
tulo da aplicação, o mesmo que também sai no
atalho, veja na Fig. 11

Directories/Conditionals:

Outra configuração muito boa, nesta opção
voce define várias regras que irão valer para todos os
projetos, regras importantes, como define o diretório
onde o executável vai ser gerado, diretório onde as
DCU’s serão geradas, estas DCU’s são os códigos
fontes compilados, se de repente você tiver uma bi-
blioteca comum numa pasta geral, voce pode definir
um caminho de pesquisa. 

Se voce estiver criando um pacote de compo-
nentes, nesta tela voce també define a pasta onde ele
serão gerados para posteriormente serem distribuidos.

Mais se no caso o arquivo gerado for um DCP,
voce terá o DCP Output Directory, para difinição da
pasta onde será gerados esse arquivos.

Outra opção bem interes-
sante, é o item de compatibili-
dade chamado de Unit Aliases,
essa vale para voce compilar
algum componente, ou apli-
cações feita em versões mais
antigas do Delphi 4, 3, etc..

Veja na Fig. 12

Fig. 10

Fig. 11
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Menu Tools

Vamos configurar
outras opções muito impor-
tantes para podermos de-
senvolver nossa primeira
aplicação, essas configu-
rações, se encontram no
menu Tools->Options, ire-
mos ver algumas somente
que serão muito impor-
tantes para nós, e para ve-
locidade no desen-
volvimento das nossas apli-
cações. 

Vamos acessar a
janela e ver essas opções,
dê uma olhada na Fig. 13

Janela Options

Na primeira opção Environment Options. 

Autosave Options:

Editor Files - salva os arquivos abertos, no Delphi
para quando voce volta a aplicação os arquivos es-
tejam na mesma posição deixada quando voce saiu.

Project desktop - Grava o Layout
usado na aplicação.

Compiling and Running:

Show compiler progress - mostra
os arquivos que estão sendo
compilados no momento.

Editor Options:

Na Fig. 14, tem as opções mar-
cadas que certamente faram
diferenças durante o desenvolvi-
mento, essas opções são de
grande importancia na veloci-
dade de desenvovimento do
código, vamos ver o conceito de

Fig. 12

Fig. 13

Fig. 14

05



06

Insert mode: Permite a inserção de código em linha de programação, ou substituição no modo Overwrite.

Group undu: Permite desfazer varias alterações no código de programa, conhecido como o famoso CTRL
+ Z.

Force cut and copy enable: Permite recortar ou copiar linhas, blocos, de código de programas.

Auto complete text to find: Permite guardar as palavras digitadas para pesquisas, facilitando as próximas
e permitindo o complemento automático quando voce for digitando as letras iniciais.

Undu after save: Permite voce desfazer alterações no código, mesmo depois dele salvo (gravado).

Overwrite blocks: Permite colar blocos de informações sobre outro já existente.

Find text at cursor: Procura o texto e posiciona o cursor no seu início.

Preserve line ends: Preserva a posição do fim de linha.

Está é mais uma opção (veja Fig. 15) que voce deve observar, aqui voce define o layout de teclado
que deseja trabalhar, a opção Default, tem como layout o atual que o windows usa, que está definido os
métodos de teclas padrão como: Ctrl + C (Copia), Ctrl + X (Recorta), Ctrl + S (Salva), F9 - compila, etc..

Para os clássicos desenvolvedores, existe uma opção de layout bem interessante, chamada BRIEF

emulation, esta usa um layout de teclado parecido com a do antigo WordStar (para os saudosista), cujo con-
junto de processos são feitos com base na tecla ALT + Letra, Veja alguns exemplos:

ALT + B - Mostra lista de programas abertos
ALT + C - Marca inicio de um bloco.
ALT + D - Apaga a linha onde o cursor está posicionado.

Também temos o uso da tecla Ctrl, veja alguns exemplos:

Ctrl + M - Insere uma nova linha.
Ctrl + K - Apaga caracteres do cursor até o início da linha.

Fig. 15
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E, finalmente estamos prontos para programar

Bem pessoal, essa foi a melhor configuração básica para deixar o Delphi 2007, parecido com o tra-
balho que eu desenvolvia no Delphi 7, para mim, essa está ótima, mais isso não que dizer que esta bom
para você, por isso explore-o bastante, e deixe a interface do Delphi 2007 o mais amigável possível, você
verar os resultados satisfatórios no desenvolvimento dos seus projetos. Deêm uma olhada no Delphi depois
de todas essas modificações. Veja Fig. 16.

Fig. 16

Bastante lite, pronto para o desenvolvimento...........

O saber torna você, mais digno, mais profissional, mais perfeito...

Até a próxima, certamente iremos nos encontrar.

Newton Santos (New)
Analista de sistemas senior.



Esclarecendo a Compatibilidade
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Tela de boas vindas do broffice.

O grande problema da aceitação do broffice, é o medo da compatibilidade, mais uma grande quanti-

dade de usuários não sabem que esta compatibilidade já é bem estreita entre as duas maiores suites de es-
critório, a paga da grande
Microsoft, e a gratuíta BrOf-

fice, essa briga é boa.

Mostraremos alguns
métodos muito bons e impor-
tantes para deixo-los mais pró-
ximos a nível de
compatibilidade entre ambas as
partes, essas configurações,
mostradas, vai fazer com que o
BrOffice 3.1, trabalhe com-
patível com o MSOffice, pois
ela não consegue ser com-
patível com o o BrOffice.

Além de outras vanta-
gens apresentadas pelo BrOffice, temos geração natural de arquivos PDF, gravação de arquivos padrão
MsOffice, como Xls, Doc, Ppt, etc., e ainda há uma grande difereça de tamanho entre os arquivos gravados
pelos dois, veja na Fig. 3.

Fig. 1

Fig. 2
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Fig. 3

Veja o arquivo “A ligeira raposa marrom ataca o cão
preguiçoso”, no formato ODF padrão openoffice, apenas
15kb, em quando o formato DOC gravado no MsWord 2003,
509kb, a diferença é absurda.

esses arquivos com qualquer usuário que tenha o
Ms Office, sem medo nenhum. Para os usuários
mais acostumados com o BrOffice, basta usar-lo no
formato de arquivo padrão, você ganhará em quali-
dade e em espaço, ai quando for mandar para outro
usuário que tenha Ms Office, use a opção Arquivo

-> Salvar Como, e grave como Arquivo do Ms Of-
fice, Word ou Excel, dependendo do tipo que esteja
usando, depois disso só enviar para a pessoa que
não abre mão do Ms Office, por medo de não dá

certo.

Eu particulamente, uso os arquivos padrão do
Br Office, e quando alguém precisa de um docu-
mento, simplemente exporto para Pdf e envio, além
de mais rápido, o Pdf é mais seguro, e, mais díficil
de alterar. 

Configurando a Compatibilidade.

Vamos fazer nossa primeira configuração
para que o BrOffice trabalhe e grave arquivo como
Ms Office, esta configuração pode ser feita por qual-
quer um dos software que compõe a suíte BrOffice

os principais são:

Base - Banco de dados

Calc - Planilha

Draw - Desenho

Impress - slides

Math - Matemática

Writer - Documentos

Execute um desses
e clique no menu Ferra-

mentas Opções, e em
seguida Carregar / Salvar,
escolha a opção Geral, na
janela da direita, você
definirá o tipo de docu-
mento que será gravado,
veja na Fig. 4, a janela de
configuração.

Nesta janela (Fig. 4), voce escolhe o tipo de
documento, pode ser planilha, documento, slide,
etc.., em sempre salvar como, escolher o tipo, no
caso de Documento de texto, escolha Microsoft

Word 97/2000/XP, agora escolha o tipo de docu-
mento Planilha e Salvar sempre como Microsoft

Excel 97/2000/XP, pronto seu BrOffice, está pronto
para salvar planilhas e documentos para Ms Office,

sem voce se preoculpar, podendo compartilhar  ->

Fig. 4
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Veja na Fig. 8, os quatro tipos de arquivos que os
programas do suite BR Office, exporta.

A outra janela de exportação aparece quando
voce clica direto na opção Exportar como PDF, isso
facilita o seu trabalho pelo fato de na maioria das
vezes, voce precisar somente da exportação de pdf,
isso seria uma atalho rápido para acesso a tela de
configuração. Veja Fig. 9.

Outro tipo de exportação por assim dizer, e o
envio do documento por email, neste caso voce tem
a opção Enviar, e das opções voce tem a Email

com o documento em formato PDF, essa é uma
opção muito boa para envio de documento para ou-
tras pessoas. 

Fig. 6

Uutras diferenças, somente lugares. 

A Ms Office e a Br Office, fizeram mudanças
simples na estrutura de menus, mais que deixam
usuários comuns de cabelos em pé, e isso é um mo-
tivo para simplesmente desistir de uma mudança,
exceto se esta for obrigatória, porém, se o usuário
for menos nervoso, irá ver que as mudanças tiveram
lógica, as opções corretas estão nos lugares corre-
tos, por exemplo:

Configurar Página

Na Microsoft está no menu Arquivos neste
há uma alusão errada, menu Arquivos é para ar-
quivos, então a Br Of-
fice fez a troca,
colocou-o no menu
Formatar, Ficando
assim mais lógico,
veja na Fig. 5 e Fig. 6.

Exportação

Foi adicionado
no Br Office, exata-
mente no menu Ar-
quivo, a opção de
Exportação, muitis-
simo interesante, pelo
fato de você poder
gravar seus documen-
tos em Pdf(aconse-
lhavel), Html ou
Xhtml, no caso de
envio de email para
terceiro, é bastante
prudente que voce
como usuário por se-
gurança exporte para
Pdf, e envie o Pdf,

este tipo de docu-mento é mais dificil de ser alte-
rado, burlado, etc., veja a fig. 7, as opções de ex-

portação.

Exportar... abre uma janela para escolha do arquivo
que voce deseja exportar seu documento, veja na
Fig. 8, Exportar como PDF..., já vai direto para a
janela de Exportação do documento PDF, veja Fig.

9, detalhe até a versão 2003 da MS Office, não tinha
a opção de Exportação.

Fig. 5

Fig. 7

Fig. 8
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Opções para exportação do PDF

Na Fig. 9, voce tem todas as opções para ex-
portação do documento atual, nela voce pode esco-
lher:

-Se vai exportar todas as folhas, as especificadas ou
as selecionadas.

-Para as imagens voce pode definir manual o nível
de compressão ou escolher compressão sem per-
das que será gerado automaticamente, e, ainda
pode reduzir a resolução das imagens em DPI.

-Nas opções gerais, geralmente deixo no formato
padrão, é o suficiente para voce exporta seu docu-
mento em PDF.

Por que a importância da configuração da
aba Geral? É importante pelo fato de que docu-
mento gerado fique num tamanho e numa qualidade
ideal para que possa ser enviado por email, depois
dessa operação o usuário deve verificar o tamanho
do arquivo gerado, geralmente nas nossa diversas
internet de empresas diferentes, o tamanho ideal de
um documento é de até 2,5 mb, isso significa que
ele não irar atrapalhar o fluxo de dados da rede, isso
não significa que você não possa enviar um arquivo
maior do que este, mais ai deve ser feito por sua
conta e risco. Fig. 9

Fig. 10

Fig. 11

Veja abaixo as barras de ferramentas dos dois principais softwares das Suites

e compare tambem as opções de menus

Veja os menus e barras de ferramentas do Writer e do Word, são bem parecidas, teste compare, ve-
rifique, com botão direito do mouse em qualquer área limpa das barra de ferramentas aparecerá o menu de
barras de ferramentas disponíveis, tire e coloque as que voce achar mais adequado para o seu trabalho.
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Fig. 12

Fig. 13

Agora os menus e barras de ferramentas dos software Calc e Excel, também bastante parecidas, ex-
plore, analise e verifique, veja que a compatibilidade entre os dois são muito grandes.

BrOffice, todos os software gratuítos, pode ser instalados em quantos pcs voce tiver na sua

empresa, atualizações, performance, e qualidade de primeira, acredite custo benefício muito

bom, vale apena testa-lo, lógico que voce terá problemas, com usuários viciados em msoffice,

mais é fácil contornar.

Marcelo  Alencar
Analista Junior

Newton Santos (New)
Analista Senior

No caso da suite MsOffice, pesa o valor

da licença, ótima suíte, porém custo benefi-

cio muito alto, veja o valor da licença stan-

dart Microsoft Office 2007 Sngl OLP NL

R$ 665,00, agora imagine multiplicado por

50 pcs., é algo de ser analizado.
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Firebird

A vez da Fenix

Banco de Dados 
Relacional
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O Banco de dados

Banco de dados relacional que cresceu muito nos últimos anos, de facíl instalação e manutenção, além
disso é multi plataforma, ou seja, pode ser instalado no Windows, no Linux (Onde ele é bastante forte), ele
é filho do interbase banco de dados respeitado da borland, mais com as implementações eles começam a se
distanciar um do outro, e o Firebird começa a ficar completamente independente, mais também vai se tor-
nando robusto e aceito em várias empresas, principalmente pelo seu custo benefício, nesta matéria iremos
ver como baixar, instalar criar banco de dados e tabelas.

Bem vamos deixar de blablabla e vamos ao que interesa, Baixando o Firebird, iremos usar a versão
2.1.2, abra o navegador e digite: www.FirebirdSql.org, veja na Fig. 1

Fig. 1

Depois de ter baixado o firebird, vamos enten-
der como deve ser instalado, bem existe duas situ-
ações, primeiro se você esta numa rede, a opção
servidor deve ser instalado no micro considerado
Servidor da rede, e a opção Minimal Client nos mi-
cros que vão fazer acesso aos bancos de dados que
serão criados no servidor, mais se você é desenvolve-
dor então a opção a ser instalada no seu micro é a
opção Servidor de preferencia opção servidor com-
pleta, iremos mostrar os dois tipo de instalação, tanto
a cliente como a servidora, vá até a pasta onde você
fez o download e execute Firebird-
2.1.2.18118_0_Win32.exe, Fig. 2

selecione o idioma e clique em ok

Fig. 2
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Fig. 3

Esta instalação sera feita
para um servidor este pode ser o
Servidor da rede ou no PC do de-
senvolvedor, o importante neste
momento é voce prestar atenção
na versão e quais componentes
serão instalados.

Clique no botão
Seguinte.

Fig. 4

Aceite o contrato e
clique no botão
Seguinte.

Veja que no contrato aceito por voce está escrito INTERBASE PUBLIC LICENSE, puxa, mais não era
o Firebird que eu estava instalando?, Calma, este contrato é baseado no Interbase Free, liberado pela Bor-
land, a partir dai surgiu o Firebird, projetado por uma comunidade open source, mais a licença deve ser a
baseada no pai do Firebird. Na Fig. 5, voce verá importante informações sobre o Firebird, se desejar dá uma
olhada tudo ok, se não iremos continuar nossa instalação.

11 4718-3527
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Fig. 5

Aqui voce encontra infor-
mações sobre o kit de insta-
lação do Fb 2.1, se quizer dar
uma olhada, vale apena.

Fig. 7

Na Fig. 6 está mostrando a
pasta onde será instalado o Fire-

bird 2.1, geralmente não se mexe
nesta opção, porém se você é ex-
pert, esteja a vontade para fazer
quaisquer alteração que desejar.

Na Fig. 7, tem todas as
opções necessárias para Servidor

ou um PC de desenvolvimento,
voce tem a opção de escolher entre
Classic Server e Super Server es-
colha a segunda, ele é mais dinâ-
mico.
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Aqui também não mu-
daria nada, simplesmente clique
em Seguinte.

Fig. 8

Fig. 9

Na Fig. 9, voce deve obser-
var as opções com batante cautela,
vamos ver:

Deixe marcado Usar o Guardian

para controlar o servidor?, o
guardian e rápido e fácil, em outra
ocasião falaremos sobre ele.

Deixe selecionado Executar como

um Serviço?, pelo fato do Windows
executar com mais garantia, e pro-
teger o gerenciador dos  bisbilho-
teiros de plantão, as 4 últimas
opções, você deve marcar todas,
vai deixar o Firebird, melhor e com-
patível com o Interbase, o seu pai.
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Pronto todas as escolhas
foram feitas, estamos quase no final,
na Fig. 10, está descrito todas as
opções que ao longo da instalção
nós selecionamos, se você quizer
dá uma avaliada, faça isso, só assim
você pode voltar e consertar. Se não
houver nada de errado, clique no
botão instalar.

Fig. 10

Aqui na Fig. 11 contém algumas infor-
mações importantes sobre o Firebird, é uma
espécie de um mini tutorial, se você é marin-
heiro de primeira viagem, vale apena dá uma
olhada, depois disso clique no botão
Seguinte.

E por fim a conclusão, é necessário
que voce reinicie o computador para que as
configurações sejam validadas, isso so-
mente se você instalou num servidor Win-
dows ou no seu PC, com Windows, se por
acaso a instalação foi feita num Linux, não
se preocupe com re-inicialização. Marque a
primeira opção, e clique no botão Concluir,
veja na Fig. 12

Fig. 11

Fig. 12
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Depois da Instalação.

e Agora ?

Boa pergunta, depois da re-inicialização, o que
fazer?.

Se você já é um programador certamente já
deve saber o que fazer, mais se você é amador,
vamos dá uma analisada na situação, primeiro não
use nunca a ferramenta de criação de bancos e
tabelas que acompanha o Firebird, ela é um saco, e
além do mais, isso seria regressão, não faz meu es-
tilo, por isso vamos baixar uma ferramenta para Win-

dows, básica e simples de usar.

Entre no Google e digite iboconsole, veja o
resultado Fig. 1---->

O site do Iboconsole para download, sem pre-
cisar do Google, é, www.mengoni.it, depois disso
clique no menu Download, e não se esqueça, escolha
o Iboconsole.zip, é mais simples para voce. Geral-
mente as pessoas constumam usar o Google, mais
isso pode ser perigoso, já que sites infectados podem
também oferecer download do iboconsole e este
pode conter vírus, cavalo de tróia, rootkit então se
puder digite o site direto no espaço destinado a digi-
tação da página Ok.

Fig. 1

Descompacte o arquivo dentro da pasta C:\Iboconsole, depois crie um atalho no Desktop, depois
disso dê um duplo clique e vamos configurar-lo para administrar bancos de dados Firebird.

Lorenzo Mengoni, é
Italiano, e criou essa
ferramenta, para
manibular banco de
dados do Firebird,
entre no site e faça
download do ibocon-

sole zipado

Fig. 2

A inovação ganhando fronteiras

Fone: 11 4718- 3527
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Fig. 3

Esta é a tela do iboconsole,
bem simples, sem firulas,
agora nós iremos configurar
para que ele acesse o servi-
dor Firebird, que está instal-
ado no seu computador ou no
seu Servidor, veja Fig. 3

Bem, agora com o botão direito do mouse, clique em
Servers, e escolha Register, irar aparecer a seguinte janela.
Fig. 4.

Nesta tela, existe duas opções, a primeira Local

Server, esta indica a configuração para o Firebird que foi
instalado no seu computador, ou seja Servidor Local. Veja
que as opções relativas ao servidor Remoto, estão desabil-
itadas, mais abaixo em Description escreva Meu PC, deixe
Save Alias Information marcado, em Login Information,
digite o usuário: SYSDBA (em maíscula), e a senha (Pass-
word): masterkey (em minúsculo), veja a Fig. 4.

Olhe agora na Fig. 5, e veja depois da configuração,
o servidor local, está pronto para receber um banco já criado,
ou para criar um do zero, clique no sinal de +, e depois com
o botão direito do mouse clique em Databases, em seguida
clique em Create Database... veja na Fig. 6

Fig. 4

Fig. 5

Fig. 6
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Fig. 7

Em uma pasta previamente criada, no
meu caso chamada de Bancos, digite no boxe
abaixo de Filename(s), veja na Fig. 7, não
precisa mexer nas outras opções, exceto as
duas últimas Register Database deve ser
marcada, em Alias digite Vendas, e depois
clique em OK.

Fig. 8

Veja, depois de criado o
banco de Dados, a tela do Ibocon-

sole ficou igual a Fig. 8, e tudo que
está abaixo de Vendas, são
opções do banco de dados para
voce incrementa-lo de forma a
atender as suas necessidades.

Opções do Banco de Dados. Fig. 8

Domains - Dominíos, cria variáveis default para campos, facilitando a criação de tabelas
Tables - Cria tabelas de dados
Views - Cria visões virtuais das tabelas de dados usando comandos SQL.
Stored Procedures - Cria funções e procedimentos no banco de dados
External Functions - Cria link com funções externas criadas pelo usuário.
Generators - Cria variáveis para utilização no banco, elas podem ser incrementáveis.
Exceptions - Cria mensagens de erros

Obs.: Blob Filters e Roles, veremos em outro momento oportuno.
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Opções do Banco de Dados. Fig. 8

Backup - Opção importante, aqui voce faz backup e restauração do Banco, diariamente.
Users - Aqui você cria usuários para utilizar o banco de dados, isso é feito para garantir a segurança. 

Fig. 9

Agora com o botão direito sobre a opção Ta-

bles, escolha a opção Create, aparecerar a tela da
Fig. 9, nesta tela você cria um Tabela, primeiro
coloque o nome (Clientes), depois column
(codigo_cli), geralmente o primeiro campo, é um
campo chave, neste caso você deve marcar Not

Null e Primary Key, escolhe agora o tipo de
campo, e pressione OK, pronto, a tabela foi criada,
o pró-ximo passo é adicionar os outros campos.

Agora para adicionar os outros campos, dê
um duplo clique na tabela (Clientes) Fig. 10, será
exibido a tela de adição e edição de campos de
uma tabela. Fig. 11

Fig. 10
Fig. 11

Na tela da Fig. 11, você adiciona os outros campos, clicando com botão direito do mouse, irar aparecer
os três comandos  básicos Novo, Editar, e Apagar, esses comandos irão ajuda-lo a administrar os campos
da tabela que está sendo criada.
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Ah, lembrando, toda vez que entra no
Iboconsole, dê um duplo clique em cima do
servidor Local ou Remoto, irar abrir a janela
de conexão do banco, simplesmente digite o
Usuário padrão = SYSDBA, Password = mas-

terkey, depois clique no botão Login. Pronto,
voce acaba se conectar no servidor, agora é
só selecionar o banco e dá um duplo clique,
para abrir o Banco, e trabalhar.

Newton dos Santos
analista de sistemas senior
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Banco de Dicas

Aumentando seu conhecimento.

Fig. 1

As dicas abaixo são interessantes para usuários legos, é sempre bom, quando o computador está em
perfeita ordem, por esse motivo as dicas desta primeira edição, é sobre o Windows XP, ou Vista.

Na Fig. 1, está sendo mostrado a tela de configuração do Windows clique na aba Inicializar (Windows
XP), e, Inicialização de Programas (Windows Vista), nesta tela estão ligados todos os programas que estão
ativos na memória, e acredite a maioria não server para nada, oculpa espaço e detona a performance do PC.

Primeiro o que você deve ter em mente é que
o necessário para o computador, é simplesmente:

1. Antivírus
2. Skype
3. Msn
4. Alguns utilitários de Wireless (se tiver)
5. Antispyware (se tiver)

isso é o necessário, acredite, o resto só atrabalha a
performance do PC. 

Você deve me perguntar, como esses progra-
mas vão para na inicialização do meu PC, eles apare-
cem quando você vai instalando alguns softwares, as
vezes necessários como: compactadores, leitores de
Pdf, programas de telefones, máquinas digitais, im-
pressoras, eles colocam na memória, os atua-
lizadores (updates), controladores, verificadores, etc.,
na verdade todos eles são lixo na memória que atra-
palha muito a peformance do computador, então toda
vez que instalar um novo software você pode execu-

tar o msconfig, e ver se foi instalado algum software
, se estiver pode desligar, exceto se ele for muito im-
portante, caso contrário pode desligar.

Limpando o Sistema.

Outra forma de melhorar a performance do sis-
tema, é fazendo uma limpeza periódica, pelo fato do
Windows ser campeão em guardar ou gerar lixo, e
isso, deixa o sistema muito lento, também é lixo de
navegação, lixo de instalação, lixo temporário de uso
de arquivo pelos aplicativos, lixo de desinstalação, é
complicado quando se trata do Sistema Operacional
Windows, e além do mais toda vez que for limpar o
sistema não se esqueça de marcar compactar ar-

quivo antigo.

Para acessar o sistema de limpeza do Windows, sim-
plesmente clique em  Iniciar, Programas,

acessórios, Ferramentas de Sistemas, agora clique
em limpeza de disco veja Fig. 2.



Fig. 2

Fig. 3
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Nessa tela Fig. 2, você escolhe a unidade que de-
seja fazer a limpeza, porém geralmente essa limpeza é
feito no HD ou seja drive C:, pressionando OK, o sistema
de limpeza calculará todos os arquivos desnecessários
para limpeza, veja Fig. 3.

Fig. 4

Geralmente seleciono todas as opções, o que
torna um pouco demorado. no Vista não existe a
opção Compactar arquivos antigos, somente no
XP, essa compactação dá uma velocidade boa no
XP, quando a limpeza é feita.

Então vale lembrar, limpezas periódicas são
de extrema importância, para o seu PC, porém não
se esqueça de fazer.

até a próxima.........

Newton dos Santos
analista de sistemas senior
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Na próxima teremos:

1. Início do Curso de “Delphi 2007 para Win 32”

2. Inicio do Curso de Banco de dados “Usando o Firebird”

3. Mil e Outras Coisas

Você não vai querer perder... Vai? 

Principais tópicos da próxima Edição

“Conhecer e Aprender”, certamente a única forma

de você ingressar no futuro, não deixe que barreira

nenhuma impessa de você pegar esse bonde.

New.

11 - 4718-3527

Mairinque - São Paulo.

www.cnpc.com.br


